C загрузка данных из excel - IT Справочник
Llscompany.ru

IT Справочник
2 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

C загрузка данных из excel

Инструкция по загрузке из Excel в 1C для программиста

Нужно загрузить большой объем данных из Экселя в 1С? Настроить постоянную загрузку накладных и товаров? Обратитесь к нам! Оставьте заявку в форме выше или позвоните нам по телефону +7 499 350 29 00.

Несомненно, одним из самых распространенных способов массового занесения информации в информационную систему является загрузка информации в 1С 8.3 из Excel. Ниже я рассмотрю пошаговое создание обработки загрузки данных и дам ссылку на скачивание её.

Данная инструкция написана для программистов, для пользователей 1С скорее подойдут следующие статьи:

  • Загрузка данных штатными методами в 1С — Загрузка из Excel на примере прайс-листа.
  • Если вам необходимо загрузить номенклатуру в 1С — пример загрузки товаров в 1С 8.3.

Самые популярные данные, которые требуются для загрузки в 1С из Excel:

  • номенклатура и её штрих-коды, в том числе с картинками;
  • накладные от поставщика;
  • прайс-листы от контрагентов;
  • начальные остатки по складам или бухгалтерскому учету.

MS Excel — программа для работы с электронными таблицами, созданная компанией Microsoft. Она предоставляет возможности экономико-статистических расчетов, графические инструменты и язык макропрограммирования VBA. Excel является одним из наиболее популярных приложений в мире.

Обработку мы будем делать универсальную, подобно той, что мы делали для загрузки файлов csv в 1С.

1. Создание обработки загрузки и её формы

Тут мы особо ничего не будем придумывать, сделаем поле ввода для выбора файла на диске, кнопку «Прочитать» для чтения файла и заполнения табличной части.

2 Обработчик выбора файла

Тут всё сделаем как в загрузке из CSV:

При нажатии на выбор файла необходимо отображать диалог выбора файла в ОС. Сделать это очень просто. Необходимо на обработчик “НачалоВыбора” в поле ввода файла указать следующий код:

3 Обработка данных из Excel и загрузка в 1С 8.3

Для начала мы очищаем информацию в таблице, находим файл на диске, подключаемся к Excel через COM-объект и проводим все технические настройки:

Получите 267 видеоуроков по 1С бесплатно:

После того как мы получили все данные из файла, мы считываем 1 строку файла и генерируем колонки на форме с наименованиями из файла:

После формирования колонок считываем тело файла эксель и построчно заносим данные в табличное поле:

В результате мы получаем загруженные данные из excel c такими же колонками:

Не забудьте закрыть Эксель в 1С после выполнения процедур с помощью кода:

Универсальную загрузку из excel в 1C можно бесплатно скачать тут.

Обратите внимание, эта обработка написана в режиме «обычного приложения 1С».

Если у Вас всё же возникли проблемы с загрузкой, Вы можете обратиться за помощью к опытному программисту 1C.

Видеоурок по загрузке товаров в 1С из файлов Excel:

Если Вы начинаете изучать 1С программирование, рекомендуем наш бесплатный курс (не забудьте подписаться на YouTube — регулярно выходят новые видео):

К сожалению, мы физически не можем проконсультировать бесплатно всех желающих, но наша команда будет рада оказать услуги по внедрению и обслуживанию 1С. Более подробно о наших услугах можно узнать на странице Услуги 1С или просто позвоните по телефону +7 (499) 350 29 00. Мы работаем в Москве и области.

Работа с файлами Excel

MS Excel давно стал стандартом для работы с электронными таблицами. В статье рассматриваются способы программной выгрузки и загрузки из 1С в файлы Excel.

Существует несколько способов программной работы с файлами Excel из 1С. Каждый из них имеет свои преимущества и недостатки.

Обмен через табличный документ

Данный способ простой. Его суть заключается в том, что объект ТабличныйДокумент имеет методы:

  • Записать ( , ) для выгрузки данных в файл;
  • Прочитать ( , ) для загрузки данных из файла.

Внимание!

Метод Записать () доступен как на клиенте, так и на сервере. Метод Прочитать () доступен только на стороне сервера. Необходимо помнить об этом
при планировании клиент-серверного взаимодействия.

Рассмотрим пример сохранения табличного документа в файл. Необходимо любым способом создать и заполнить объект ТабличныйДокумент, а выгрузка в файл осуществляется всего лишь одной строкой:

ТабДок . Записать ( ПутьКФайлу , ТипФайлаТабличногоДокумента . XLSX );

Здесь ТабДок — сформированный табличный документ, ПутьКФайлу — имя файла для выгрузки, ТипФайлаТабличногоДокумента.XLSX — формат создаваемого файла. Поддерживаются следующие форматы Excel:

  • XLS95 — формат Excel 95;
  • XLS97 — формат Excel 97;
  • XLSX — формат Excel 2007.

Загрузка из файла осуществляется также достаточно просто:

ТабДок = Новый ТабличныйДокумент ;
ТабДок . Прочитать ( ПутьКФайлу , СпособЧтенияЗначенийТабличногоДокумента.Значение );

Здесь ПутьКФайлу — путь к загружаемому файлу Excel. СпособЧтенияЗначенийТабличногоДокумента.Значение определяет, каким образом нужно интерпретировать данные, считываемые из исходного документа. Доступны варианты:

Обмен через OLE

Обмен через технологию OLE automation, пожалуй, самый распространенный вариант программной работы с файлами Excel. Он позволяет использовать весь функционал, предоставляемый Excel, но отличается медленной скоростью работы по сравнению с другими способами. Для обмена через OLE требуется установка MS Excel:

  • На компьютере конечного пользователя, если обмен происходит на стороне клиента;
  • На компьютере сервера 1С:Предприятие, если обмен происходит на стороне сервера.

Пример выгрузки:

// Создание COM-объекта
Эксель = Новый COMОбъект ( «Excel.Application» );
// Отключение вывода предупреждений и вопросов
Эксель . DisplayAlerts = Ложь;
// Создание новой книги
Книга = Эксель . WorkBooks . Add ();
// Позиционирование на первом листе
Лист = Книга . Worksheets ( 1 );

// Запись значения в ячейку
Лист . Cells ( НомерСтроки , НомерКолонки ). Value = ЗначениеЯчейки ;

// Сохранение файла
Книга . SaveAs ( ИмяФайла );

// Закрытие Эксель и освобождение памяти
Эксель . Quit ();
Эксель = 0 ;

Читать еще:  Открытие excel c

Примеры чтения:

// Создание COM-объекта
Эксель = Новый COMОбъект ( «Excel.Application» );
// Открытие книги
Книга = Эксель . Workbooks . Open ( ПутьКФайлу );
// Позиционирование на нужном листе
Лист = Книга . Worksheets ( 1 );

// Чтение значения ячейки, обычно здесь располагается цикл обхода ячеек
ЗначениеЯчейки = Лист . Cells ( НомерСтроки , НомерКолонки ). Value ;

// Закрытие книги
Книга . Close ( 0 );

// Закрытие Эксель и освобождение памяти
Эксель . Quit ();
Эксель = 0 ;

// Открытие книги
Книга = ПолучитьCOMОбъект ( ПутьКФайлу );
// Позиционирование на нужном листе
Лист = Книга . Worksheets ( 1 );

// Чтение значения ячейки, обычно здесь располагается цикл обхода ячеек
ЗначениеЯчейки = Лист . Cells ( НомерСтроки , НомерКолонки ). Value ;

// Закрытие книги
Книга . Application . Qui t ();

Для обхода всех заполненных строк листа Excel можно использовать следующие приемы:

// —— ВАРИАНТ 1 ——
КоличествоСтрок = Лист . Cells ( 1 , 1 ). SpecialCells ( 11 ). Row ;
Для НомерСтроки = 1 По КоличествоСтрок Цикл
ЗначениеЯчейки = Лист . Cells ( НомерСтроки , НомерКолонки ). Value ;
КонецЦикла;

// —— ВАРИАНТ 2 ——
НомерСтроки = 0 ;
Пока Истина Цикл
НомерСтроки = НомерСтроки + 1 ;
ЗначениеЯчейки = Лист . Cells ( НомерСтроки , НомерКолонки ). Value ;
Если НЕ ЗначениеЗаполнено ( ЗначениеЯчейки ) Тогда
Прервать;
КонецЕсли;
КонецЦикла;

Вместо последовательного обхода всех строк листа можно выгрузить все данные в массив и работать с ним. Такой подход будет быстрее при чтении большого объема данных:

ВсегоКолонок = Лист . Cells ( 1 , 1 ). SpecialCells ( 11 ). Column ;
ВсегоСтрок = Лист . Cells ( 1 , 1 ). SpecialCells ( 11 ). Row ;

Область = Лист . Range ( Лист . Cells ( 1 , 1 ), Лист . Cells ( ВсегоСтрок , ВсегоКолонок ));
Данные = Область . Value . Выгрузить ();

В таблице ниже приведены наиболее востребованные свойства и методы для работы с Excel через OLE:

Для того, чтобы узнать какое свойство нужно менять или какой метод вызвать можно воспользоваться макросами Excel. Если записать макрос с требуемыми действиями, то после можно посмотреть программный код на VBA записанного макроса.

Использование COMSafeArray

При выгрузке больших объемов данных из 1С в Excel для ускорения можно использовать объект COMSafeArray. Согласно определению из синтакс-помощника, COMSafeArray — объектная оболочка над многомерным массивом SafeArray из COM. Позволяет создавать и использовать SafeArray для обмена данными между COM-объектами. Проще говоря, это массив значений, который можно использовать для обмена между приложениями по технологии OLE.

// Создание COMSafeArray
МассивКом = Новый COMSafeArray ( «VT_Variant» , ВсегоКолонок , ВсегоСтрок );
// Заполнение COMSafeArray
Для Стр = 0 По ВсегоСтрок — 1 Цикл
Для Кол = 0 По ВсегоКолонок — 1 Цикл
МассивКом . SetValue ( Кол , Стр , Значение );
КонецЦикла;
КонецЦикла;
// Присвоение области листа Excel значений из COMSafeArray
Лист . Range ( Лист . Cells ( 1 , 1 ), Лист . Cells ( ВсегоСтрок , ВсегоКолонок )). Value = МассивКом ;

Обмен через ADO

Файл Excel при обмене через ADO представляет собой базу данных, к которой можно обращаться при помощи SQL-запросов. Установка MS Excel не требуется, но обязательно наличие драйвера ODBC, при помощи которого будет осуществляться доступ. Используемый драйвер ODBC определяется при указании строки соединения к файлу. Обычно требуемый драйвер уже установлен на компьютере.

Обмен через ADO заметно быстрее обмена через OLE, но при выгрузке нет возможности использовать функционал Excel для оформления ячеек, разметки страниц, задания формул и т.д.

Пример выгрузки:

// Создание COM-объекта для соединения
Соединение = Новый COMОбъект ( «ADODB.Connection» );

// Установка строки соединения
Соединение . ConnectionString = «
|Provider=Microsoft.ACE.OLEDB.12.0;
|Data Source=» + ИмяФайла + «;
|Extended Properties=»»Excel 12.0 XML;HDR=YES»»;» ;
Соединение . Open (); // Открытие соединения

// Создание COM-объекта для команды
Команда = Новый COMОбъект ( «ADODB.Command» );
Команда . ActiveConnection = Соединение ;

// Присвоение текста команды для создания таблицы
Команда . CommandText = «CREATE TABLE [Лист1] (Колонка1 char(255), Колонка2 date, Колонка3 int, Колонка4 float)» ;
Команда . Execute (); // Выполнение команды

// Присвоение текста команды для добавления строки таблицы
Команда . CommandText = «INSERT INTO [Лист1] (Колонка1, Колонка2, Колонка3, Колонка4) values (‘абвгдеё’, ‘8/11/2017’, ‘12345’, ‘12345,6789’)» ;
Команда.Execute(); // Выполнение команды

// Удаление команды и закрытие соединения
Команда = Неопределено;
Соединение . Close ();
Соединение = Неопределено ;

Для создания нового листа и формирования его структуры можно воспользоваться объектами ADOX.Catalog и ADOX.Table. В этом случае код примет вид:

// Создание COM-объекта для работы с книгой
Книга = Новый COMОбъект ( «ADOX.Catalog» );
Книга . ActiveConnection = Соединение ;

// Создание COM-объекта для работы со структурой данных на листе
Таблица = Новый COMОбъект ( «ADOX.Table» );
Таблица . Name = «Лист1» ;
Таблица . Columns . Append ( «Колонка1» , 202 );
Таблица . Columns . Append ( «Колонка2» , 7 );
Таблица . Columns . Append ( «Колонка3» , 5 );
Таблица . Columns . Append ( «Колонка4» , 5 );

// Создание в книге листа с описанной структурой
Книга . Tables . Append ( Таблица );
Таблица = Неопределено;
Книга = Неопределено;

В приведенном примере в методе

Таблица . Columns . Append ( «Колонка1» , 202 );

во втором параметре указывается тип колонки. Параметр необязательный, вот некоторые значения типа колонки:

  • 5 — adDouble;
  • 6 — adCurrency;
  • 7 — adDate;
  • 11 — adBoolean;
  • 202 — adVarWChar;
  • 203 — adLongVarWChar.

Пример чтения:

// Создание COM-объекта для соединения
Соединение = Новый COMОбъект ( «ADODB.Connection» );

// Установка строки соединения
Соединение . ConnectionString = «
|Provider=Microsoft.ACE.OLEDB.12.0;
|Data Source=» + ИмяФайла + «;
|Extended Properties=»»Excel 12.0 XML;HDR=YES»»;» ;
Соединение . Open (); // Открытие соединения

// Создание COM-объекта для получения выборки
Выборка = Новый COMОбъект ( «ADODB.Recordset» );
ТекстЗапроса = «SELECT * FROM [Лист1$]» ;

// Выполнение запроса
Выборка . Open ( ТекстЗапроса , Соединение );

// Обход результата выборки
Пока НЕ Выборка . EOF () Цикл
ЗначениеКолонки1 = Выборка . Fields . Item ( «Колонка1» ). Value ; // Обращение по имени колонки
ЗначениеКолонки2 = Выборка . Fields . Item ( 0 ). Value ; // Обращение по индексу колонки
Выборка . MoveNext ();
КонецЦикла;

Выборка . Close ();
Выборка = Неопределено;
Соединение . Close ();
Соединение = Неопределено;

В строке соединения параметр HDR определяет как будет восприниматься первая строка на листе. Возможны варианты:

  • YES — первая строка воспринимается как названия колонок. К значениям можно обращаться по имени и по индексу колонки.
  • NO — первая строка воспринимается как данные. К значениям можно обращаться только по индексу колонки.
Читать еще:  Элементы управления activex в excel

В приведенных примерах рассмотрено лишь несколько объектов ADO. Объектная модель ADO состоит из следующих объектов:

Выгрузка без программирования

Для сохранения данных из 1С в Excel не всегда целесообразно прибегать к программированию. Если в режиме Предприятия пользователь может отобразить требуемые для выгрузки данные, то, их возможно сохранить в Excel без программирования.

Для сохранения табличного документа (например, результата отчета) можно вызвать команду Сохранить или Сохранить как… главного меню.

В открывшемся окне требуется выбрать каталог, имя и формат сохраняемого файла.

Для сохранения данных динамических списков (например, списка номенклатуры) необходимо:

  1. Вывести данные в табличный документ при помощи команды Еще ⇒ Вывести список…;
  2. Сохранить табличный документ в требуемый формат.

Остались вопросы?
Спросите в комментариях к статье.

C загрузка данных из excel

Первое, с чем мне пришлось столкнуться при знакомстве с 1С — Загрузка данных из Excel…
Загрузка нужна была в нашей компании везде: продажи, закупки, характеристики, изменение цен и тд.

Ну и, как полагается, еще совсем зеленым я не особо понимал что и как делается.
Так что, если кто-то из Вас только начинает погружаться в удивительный мир возможностей 1С, знайте, у Вас все впереди!
Ничего страшного в незнании чего-либо НЕТ! Всегда можно найти ответ на любой вопрос и решить практически любую задачу!

Итак, загрузка из файла Excel в табличную часть любого документа…

Для примера создадим обработку с табличной частью.

К кнопке «Заполнить» привяжем нашу процедуру:

Теперь давайте посмотрим, как то все отработает.

В обработке нажимаем кнопку «Заполнить».

Открывается стандартный диалог открытия файлов.

Снизу справа видим наш фильтр, который дает открывать только файлы Excel.

Выбираем наш файл Тест.xls

Тестовый файл выглядит следующим образом:

Т.е. к примеру клиент прислал нам заказ, нам его нужно загрузить в реализацию.

После выбора файла нам предложат ввести номера колонок для конкретного файла:

Вводим соответствующие номера.

После этого начинается перебор файла и в итоге мы получаем следующий результат:

Все позиции нашлись, артикул подтягивали из номенклатуры, цены и количество так же загрузились в свои колонки.

Так же, после чтения каждой строки, можно выводить различные служебные сообщения, например, какая номенклатура нашлась, какая не нашлась и так далее.

От себя добавлю, что данную процедуру мы используем очень часто и в различных ситуациях.

Если у вас возникнут какие либо вопросы по данной обработке или заметите какую либо ошибку — пишите в комментариях, с удовольствием отвечу!

Администратор

Навигация по записям

Отправка писем из 1С

4 комментария к “ Загрузка данных в табличную часть документа из Excel ”

ДиалогВыбораФайла нельзя писать на сервре, а на клиенте нельзя обращаться к справочнику

Я, к сожалению, на данный момент работаю только с обычными формами, там все выполняется на клиенте и они директивы &НаСервере и &НаКлиенте не воспринимают…

А как загрузить в одну ТЧ строки из нескольких книг xls? Есть идеи?

Есть конечно! 🙂
Но боюсь, что задержался с ответом))
А в целом, в диалоге выбора файла изменяем доступность Множественного выбора
ВыборФайла.МножественныйВыбор = Истина;

Убираем проверку выбора файла:
//Проверим, выбрали ли мы файл, с помощью проверки заполненности пути до файла
Если ПустаяСтрока(ВыборФайла.ПолноеИмяФайла) Тогда
Сообщить(«Файл не выбран»);
//Если мы файл не выбрали, то процедура прерывается, так как продолжать ее нет смысла.
Возврат;
Иначе
Сообщить(«Вы выбрали файл — «+ВыборФайла.ПолноеИмяФайла);
КонецЕсли;

Переносим указание переменных артикул количество цена пораньше
//Теперь у нас есть практически все, что необходимо для загрузки данных.
//Проставим нужные нам колонки
ВвестиЧисло(Артикул,»Введите номер колонки Артикул»,2,0);
ВвестиЧисло(Количество,»Введите номер колонки Количество»,2,0);
ВвестиЧисло(Цена,»Введите номер колонки Цена»,2,0);

Ставим код сразу после:
//Открываем диалог выбора файла
ВыборФайла.Выбрать();

И берем в цикл наше заполнение:
Для Каждого стр Из ВыборФайла.ВыбранныеФайлы Цикл

//Создаем переменную для хранения пути к файлу
ПутьКФайлу = стр;
…..

Закрываем цикл в конце обработки
ПриложениеExcel.Quit();
КонецЦикла;

Это так, первое что пришло на ум из работоспособного. Можно немного более оптимизированным сделать код, что бы Excel только один раз открывался программно, ну и еще по мелочи.

Лучшие IT-решения для бизнеса

Nav view search

Navigation

Search

Программирование, доработки консультации по 1С

Как мы работаем

1. Обсуждаем проблему по телефону. При наличии удаленного доступа — показываете на экране вашего компьютера.

2. Мы оцениваем работу в рублях, если проект большой, если нет — примерное кол-во часов.

3. Мы выполняем работу.

4. Вы принимаете работу в вашей программе, если есть недочеты мы их исправляем.

5. Мы выставляем счет, вы оплачиваете.

Стоимость работ

1. Все работы делятся на 3 категории: консультация, обновление типовой конфигурации, разработка или программирование нового отчета, обработки, кнопки и т.п.

2. Стоимость работ по категориям:

3. На работы более 10 часов предварительно составляется техническое задание с описанием и стоимостью работ. Работы начинаются после согласования ТЗ с вами.

Техническая поддержка

1. Если вы обнаруживаете какие то ошибки, в ранее принятых работах, в течении 3х месяцев, мы исправляем их бесплатно.

2. Постоянным клиентам любые недочеты, допущенные в наших работах, исправляем бесплатно в течении года.

Программы для управления вашим бизнесом.

Купить 1С:Предприятие

Читать еще:  Посчитать символы в ячейке excel

Мы являемся официальным дилером фирмы 1С, вы можете приобрести у нас различные программные продукты и лицензии. Кроме покупки «коробки» мы поможем вам настроить программу, проконсультируем и сделаем базовые настройки.

  • Бухгалтерский учет
  • Автоматизация магазина
  • Оптовые продажи
  • Помощь в установке и первоначальной настройке включена в пакет!
  • Тонкая настройка конфигураций под нужды заказчика, разработка новых модулей при отсутствии необходимых функций в стандартной конфигурации.

Предоставление сервера.

Моментальная настройка сервер + 1С.

Нет сервера? Не беда, подберем и быстро настроим сервер в «облаке». За небольшую плату вы получаете очень надежное решение.

  • Доступность 247
  • Нет необходимости держать собственного системного администратора (экономия покроет расходы на ваш сервер).
  • Быстрая настройка и установка 1С на сервер, через 3 дня у вас уже будет полностью рабочая система.
  • В любой момент можно переехать на локальный сервер, если решение не устроит.

SMS из вашей 1С

Хотите чтобы клиенты во время узнавали об акциях, скидках? Клиенты не возвращаются? Настройте отправку SMS прямо из 1С!

Наша компания сможет в короткие сроки настроить отправку SMS Вашим клиентам напрямую из 1С. Примеры событий которые можно автоматизировать:

  • Благодарность за покупку и начисление бонусов сразу после очередной покупки.
  • Начисление бонусов на карту в подарок на день рожденияк другому знаменательному или праздничному дню.
  • Извещение о поступлении товара на склад.
  • Истечение срока подарочных бонусов.
  • Извещение о поступлении предоплаты и резервирования товара.
  • Адрес с уточнениями проезда к магазинуофису, номера телефонов.
  • И т.п.

Настройку в 1С можно произвести силами наших специалистов или своих сотрудников. Ознакомится с тарифами можно на странице SMS-тарифов.

  • Гарантия доставки SMS, деньги снимаются только за доставленные SMS.
  • Отдельная тарификация каждого SMS.
  • Пополнение баланса разными способами.
  • Просмотр истории всех отправленных SMS в любой момент.
  • Имя отправителя вместо цифрового номера в телефоне получателя сообщения.

C загрузка данных из excel

Загрузка данных из документа, сформированного в формате XML, в Личном кабинете выполняется в следующем порядке:

  1. Нажмите кнопку Загрузить из файла:
    • либо в списке документов в колонке Действия,
    • либо в веб-форме документа на панели действий.

По кнопке Выбрать найдите и выберите файл, содержащий данные документа в формате XML. Рис. 1. Окно выбора файла для загрузки

В результате выполнения операции поля веб-формы документа заполняются данными из файла в формате XML.

Выгрузка данных во внешний файл в формате *.XML

Данные, ввведенные в документ, в любое время можно сохранить в виде внешнего файла в формате XML. Таким образом, например, можно сохранить документ с целью последующего использования для формирования новых документов.

Выгрузка документа во внешний файл в формате XML выполняется в следующем порядке:

  1. Нажмите кнопку Выгрузить в файл:
    • либо в списке документов в колонке Действия,
    • либо в веб-форме документа на панели действий.
  2. Затем с помощью стандартных функций вашего ПК и браузера выберите папку, в которую следует поместить выгружаемый файл, и сохраните файл. (Запрос указания папки для документа НЕ появится, если в настройках браузера установлена по умолчанию папка для сохранения файлов. Для определения папки по умолчанию или изменения настроек браузера обратитесь к системному администратору) .

В результате выполнения операции в указанной папке будет сохранен электронный документ в формате XML.

Загрузка данных из внешнего файла в формате Excel

В сервисах ЛК для некоторых документов, в которых данные/часть данных вводятся в таблицу (например, сведения о товарах/товарной партии или список документов с реквизитами), реализована возможность загрузить табличные данные, сформированные во внешнем файле формата MS Excel.

Загрузка данных из файла Excel в таблицу выполняется в следующем порядке:

Откройте окно загрузки файла Excel по ссылке Загрузить из Excel над таблицей данных. Рис. 2. Загрузка в таблицу сведений из файла Excel

По ссылке Скачать шаблон скачайте и сохраните файл-шаблон в формате Excel для заполнения данными к загрузке.

Рис. 3. Загрузка шаблона для ввода сведений о товарах
Подготовьте файл-шаблон для загрузки в документ – введите в предлагаемую в шаблоне таблицу данные и сохраните файл. При этом ничего не меняйте в файле-шаблоне: НЕ меняйте наименования колонок, их расположение, формат данных в ячейках.

Снова откройте окно загрузки файла Excel по ссылке Загрузить из Excel (см. Рис. 2) и по кнопке Выберите файл (Рис. 4) найдите и выберите подготовленный вами файл с данными.

Рис. 4. Выбор файла Excel со сведениями о товарах для загрузки

  • Ответьте на запрос системы: удалять или нет из таблицы все добавленные ранее строки данных?
  • В результате выполнения загрузки данные из файла Excel переносятся в таблицу документа. При этом если в таблице уже имелись строки с данными и вы отказались их удалять при запросе системы, то загруженные из файла данные добавляются в таблицу как дополнительные строки.

    Выгрузка данных во внешний файл в формате Excel

    В некоторых документах, содержащих информацию в виде таблицы, можно выгрузить данные из таблицы во внешний файл в формате MS Excel.

    Выгрузка данных из таблицы в файл Excel выполняется в следующем порядке:

    Нажмите ссылку Выгрузить в Excel над таблицей данных.

    Рис. 5. Выгрузка сведений из таблицы в файл Excel

  • Затем с помощью стандартных функций вашей операционной системы выберите папку, в которую следует поместить выгружаемый файл, откорректируйте название файла и сохраните файл.
  • В результате выполнения операции в указанной папке будет сохранен файл в формате Excel с табличными данными.

    Ссылка на основную публикацию
    ВсеИнструменты 220 Вольт
    Adblock
    detector